How can we help?

Home > Integrations > Turnitin Partner Integrations > Moodle > Moodle Supported Versions

Moodle Supported Versions

Posted: 24 May 2016

 

To ensure plenty of time for a smooth and straightforward upgrade, we are extending our support for the Moodle Direct V1 plugin.

 

This means that Turnitin's Moodle Direct V1 plugin will be supported alongside Moodle 3.0 until further notice. Our latest build (2016030101) has been tested against Moodle 3.0, and you can download the plugin from Moodle.org.

 


 

Posted: 2nd November 2015

We are aligning ourselves more closely with Moodle and the versions they support. From 1st November 2015, development and support for Moodle versions 2.5 and below will stop. This includes work on new features and functionality, and plugin compatibility with Moodle versions 2.5 and below.


Institutions running Moodle version 2.5 and below after the 1st November 2015 may not be compatible with newer versions of the Turnitin Moodle plugins. Both the Turnitin Moodle Direct V1 and V2 plugins will be affected by this change.


Critical development work will continue to be completed on both Turnitin Moodle Direct V1 and V2 when necessary, in order to address any possible security flaws that we believe to be severe.


Also, from 1st November 2015,  Turnitin Moodle Direct V1 will not be supported and/or tested against future versions of Moodle; this includes Moodle 3.0. We would advise that any institutions who are looking to move to Moodle 3.0 look to upgrade to our Direct V2 plugin.


We are currently working on developing a migration tool to assist institutions moving from V1 to V2, more
information to follow shortly.


Further Details


Moodle Direct V1 (superseded by V2)


Supports Moodle versions 2.6 ­and 2.9 only


Although Moodle Direct V1 has been superseded by Moodle Direct V2, we will continue to provide maintenance updates and support for Moodle Direct V1 running on Moodle versions 2.6 ­ 2.9.


Please note that we will not be upgrading Moodle Direct V1 to work with any version of Moodle beyond version 2.9.


Moodle Direct V2


Moodle versions 2.6 ­ 2.9+ (including minor releases)


All new releases of Turnitin Direct V2 plugins will continue to be developed to ensure compatibility with the listed Moodle versions. New features and functionality will also be added into plugins compatible with the listed Moodle versions.


Moodle versions below 2.6


For Direct V1 and V2 users, minimal support will be provided via the Turnitin Helpdesk to answer questions and queries to institutions using plugins compatible with Moodle versions prior to 2.6.

 

Full support requiring engineering resources will not be made available. Additionally, no new features or functionality will be released for plugins being used with Moodle versions below 2.6. However, development resource will be made available to address any possible security flaws we believe to be severe. As such, we advise institutions to consider upgrading their instance of Moodle to at least version 2.6 to retain full support and compatibility with Turnitin.


Why have we implemented this change?


Turnitin has maintained and supported versions of Moodle that Moodle themselves have stopped supporting. We feel that this decision is necessary to enable us to dedicate more time developing against more recent versions of Moodle.


Further Resources


Moodle release and support dates 

Turnitin downloads page

General help pages on the Turnitin Moodle plugin

 

If you have any further questions, please contact our Product Support Team by emailing
tiisupport@turnitin.com.

You must to post a comment.
Last modified
10:55, 24 May 2016

Tags

This page has no custom tags.

Classifications

(not set)